Eski sürüm IE tarayıcılarını güncellemek (abTarayici)

Bu eklentimiz sanıyorum ki bir çok internet sitesi geliştiricinin en sevdiği eklenti olacak çünkü internet sitelerini geliştirmemizi engelleyen tarayıcıları yavaş yavaş kullanıcılara öğreterek yeni sürümlere tatlı bir dille yönlendirebileceğiz.


abTarayici1 abtarayici2

abTarayici V0.1 özellikleri

  • Belirttiğimiz sürüm altındali tarayıcılar için uyarı gösterilir.
  • Uyarıları cookie sayesinde günde 1 sefer veya her sayfa yüklendiğinde gösterilir.
  • Uyarıdaki metinleri isteğimiz gibi değiştirebiliriz
  • Yeni tarayıcı indirme linkini isteğimize göre değiştirebiliriz.

Hızlı Kullanım

Head tagları arasına yukarıda ki script kodunu eklediğiniz taktirde internet sitenizde ie9 altı tarayıcılarda sayfa her yüklendiğinde uyarı çıkacaktır.

Basit Kullanım

İnternet explorer 9 altındaki tarayıcılarda uyarı gösterilir, cookie tutmaz sayfa her yüklendiğinde çalışır.

Gelişmiş Kullanım

  • ‘ie’ : Buradaki sayı internet explorer sürümlerini belirtir. örn (9 == İnternet Explorer 9).  ie : 9 yazıldığında İnternet explorer 9 dan daha eski sürümlerde bu uyarı gösterilir.
  • ‘cookie’ : -1 yazdığımızda sayfa her yüklendiğinde açılır. bu sayıyı 1 yaparsak eğer günde 1 kere açılır.
  • ‘ieLink’ : Yeni tarayıcı indirme linkini isteğimize göre değiştirebiliriz.
  • ‘tarayiciBuyukYazi’ : Uyarı içindeki büyük yazı
  • ‘tarayiciKucukYazi’ : Uyarı içindeki küçük yazı
  • ‘acilmaZaman’ : Uyarının sayfa yüklendikten sonraki açılma süresi

Şuan aycan.net’e ie9 altı bir tarayıcı ile girerseniz uyarıyı göreceksiniz.

Kaynaklar :